分享是一种生活态度,求知,求真,分享工作,分享生活!

Cisco统一CME系统级功能的配置

Cisco iqianyue 2203次浏览 0个评论 扫描二维码

安装Cisco Unified Communication Manager Express

  1. Cisco Unified Communications Manager Express—-CME 统一通讯快速管理器,必须购买如下授权:IOS授权(IOS license)、功能授权(feature license)、电话用户授权(phone user license)
  2. 在Cisco路由器上安装Unified CME,将CME软件导入路由器

#archive  tar  /xtract  tftp:// ip address/文件名.tar  flash:

  1. 设置路由器为TFTP服务器,传输支持IP电话固件文件

(config)# tftp-server falsh:文件名 alias 文件名

  1. 配置CME系统级功能:

(config)# telephony-service

(config-telephony)# max-ephones NO (不能高于电话用户授权数)

(config-telephony)# max-dn NO (太大会影响闲置大量资源,影响其它服务)

  1. 为每种IP话机指定固件加载文件

(config-telephony)# load 型号 文件名

具体型号和文件对应可以google搜索Cisco Unified CME Supported Firmware

  1. 配置源IP地址信息

(config-telephony)# ip source-address IP地址

当有多条路径或者多个VLAN到达CME时可使用回环接口IP地址做为源IP地址

  1. 生成配置文件

(config-telephony)# create  cnf-files

#show telephony-service tftp-bindings

XMLDefault.cnf.xml是默认的配置文件可以提供IP话机3条信息:使用正确的端口(通常为2000)、CME路由器IP地址、电话固件信息

#more system:/its/XMLDefault.cnf.xml 查看具体的默认配置内容

  1. 配置CISCO设备时钟

(config)# net server 64.183.56.58

(config)# clock timezone china +8

(config)# clock set xxxxxxxxx

CME IP电话基本配置

  1. 为语音配置专用VLAN

(config-if)# switchport mode access

(config-if)# switchport access vlan 200

(config-if)# switchport voice vlan 100

(config-if)# spanning-tree portfast

  1. DHCP服务

(config)# ip dhcp excluded-address (start_ip_address) (end_ip_address) 去除不分配IP地址

(config)# ip dhcp pool name

(dhcp-config)# network 172.16.1.0  255.255.255.0

(dhcp-config)# default-router 172.16.1.1

(dhcp-config)# option 150 ip 172.16.1.1

(dhcp-config)# ip helper-address [ip_address of DHCP] 如果DHCP和话机不在一VLAN的话

(dhcp-config)# dns-server 4.2.2.2

  1. TFTP服务

(config-telephony)# load 型号 文件名

  1. 配置Ephone-DN,可有两种工作模式:单线 single-line ephone-dn;双线dual-line ephont-dn

(config)# ephone-dn NO1 [dual-line]

(config-ephone-dn)# number 1000 [secondary 10001000]

  1. 配置Ephone,将特定的Ephone号码对应到具体的IP话机的MAC

(config)# ephone NO2

(config-ephone)# mac-address [mac_address_A]

#show ephone

  1. 关联Ephones和Ephone-DN

(config)# ephone NO2

(config-ephone)# button 1:NO1   (若NO1为10)

(config-ephone)# restart

将1000分配给IP话机A的第一个键,使用标准化铃音

(config-ephone)# button 1b10将1000分配给IP话机A的第一个键,使用呼叫等待蜂鸣,无铃声

(config-ephone)# button 1f10将1000分配给IP话机A的第一个键,使用三倍振铃

(config-ephone)# button 1m10将1000分配给IP话机A的第一个键,监控:只能查看不能使用

(config-ephone)# button 1o10将1000分配给IP话机A的第一个键,覆盖线路(无呼叫等待)常用来在多个ephone中创建一次共享线路

(config-ephone)# button 1c10将1000分配给IP话机A的第一个键,覆盖线路(有呼叫等待)

(config-ephone)# button 1×10将1000分配给IP话机A的第一个键,覆盖扩展,可将呼叫转移至IP电话其它线路上

(config-ephone)# button 1s10将1000分配给IP话机A的第一个键,静音模式

(config-ephone)# button 1w10将1000分配给IP话机A的第一个键,观察模式

BUTTON数目和IP话机类型相关,可根据要求增加

  1. 使用共享线路和覆盖功能(P105)

O  separator 无呼叫等待的覆盖线路

C  separator 带呼叫等待的覆盖线路

X  separator 线路翻转到其它线路的覆盖线路

Preference 确定哪个ephone-DN更合适,0 – 10 越小越好

Huntstop 停止通过该ephone-DN寻找其它匹配

Huntstop  channel 停止通过该ephone-DN信道寻找其它匹配

  1. IP电话注册的故障排除

①  话机停留在“configuring IP”然后重启,是关于DHCP服务的问题:确定话机IP地址为语音VLAN的地址;若一直不显示IP地址,则是VLAN和DHCP配置问题,确认配置“ip helper-address”

②  “configuring IP”之后会变为“configuring CM List”,这时IP话机尝试去下载TFTP服务器上的配置文件,若一直持续显示该信息(多于30秒)则TFTP和话机通信故障:第一步 用TFTP服务器PING电话的IP地址,保证通信无误;第二步验证该TFTP服务器服务了正确的文件,最好使用“debug tftp events”来验证,也可用“show telephony-service tftp-bindings”验证CME提供的文件,可使用“debug ephone”来观察CME和IP电话之间的通信

  1. 支持IP话机的自动注册和自动分配

自动注册的好处是有利于CISCO IP电话的ephone表项和MAC地址能尝试与CME路由器一起注册,然后可以将MAC复制到实际的ephone表项,为设备进行线路配置。

自动分配(auto assign)命令允许将指定的ephone-DN范围分配给指定类型的的电话或者任意请求分机号码的电话。

(config)#  telephony-service

(config-telephony)# auto assign 20 to 24 type [型号]

(config-telephony)# auto assign 31 to 39

将ephone-DN 20至24分配给特定的型号的话机,将ephone-DN 31至39分配给任意请求分机号的话机

基于以下原因可以不启动自动注册:

可使用“show ephone attempted-registrations”命令来获取所有IP话机的MAC地址

自动注册虽没有ephone选项,但仍会扣除CME路由器的max-ephone值

可通过“no auto-reg-ephone”来关闭

  1. 其它IP电话配置参数

重启IP话机:restart 热启动;reset 冷启动

(config-telephony)# restart [all / mac_address]

(config-telephony)# reset [all / address]

(config-ephone)# restart

(config-ephone)# reset

电话语言设置:用户区域设置 user-locale;网络区域设置 network-locale

(config-telephony)# user-locale [代码]

(config-telephony)# network-locale [代码]

在单一系统中支持不同的IP区域设置

(config-telephony)# user-locale 1 [代码]

(config-telephony)# user-locale 2 [代码]

(config-telephony)# network-locale 1 [代码]

(config-telephony)# network-locale 2 [代码]

(config)# ephone-template 1

(config-ephone-template)# user-locale 1

(config-ephone-template)# network-locale 1

(config)# ephone-template 2

(config-ephone-template)# user-locale 2

(config-ephone-template)# network-locale 2

(config-ephone-template)# exit

(config)# ephone 10

(config-ephone)# ephone-template 1

(config)# ephone 11

(config-ephone)# ephone-template 2

日期和时间格式

(config-telephony)# date-format [格式]

(config-telephony)# time-format [格式]

系统信息

(config-telephony)# system message [话机显示信息]

配置Cisco Unified CME语音功能

  1. 配置语音网络目录

(config)# ephone-dn 20

(config-ephone-dn)# name [name]

系统默认按名字字母排列,也可通过“directory entry”命令手动添加目录项

(config)# telephony-service

(config-telephony)# directory [ last-name-first / first-name-first ]

(config-telephony)# directory entry [1-100] xxxx name [name]

  1. 通过CLI进行呼叫前转

(config)# ephone-dn 20

(config-ephone-dn)# call-forward busy xxxx

(config-ephone-dn)# call-forward noan xxxx timeout 25

  1. 配置呼叫转移:询问转移——–按下tranfer输入分机号接通后,再按tranfer,线路数要两条以上或者dual-line配置;盲转—–按下tranfer输入分机号完成转接,可工作在single-line模式

(config)# telephony-service

(config-telephony)# transfer-system  [ full-bind / full-consult / local-consult ]

全盲转移/全询问转移/本地询问转移

注:本地询问为CISCO特有,多条线路话机使用询问转移,一条线路使用全盲转移

或:(config)# ephone-dn 20

(config-ephone-dn)# transfer-mode [ blind / consult ]

允许CME向外转移的模式

(config)# telephony-service

(config-telephony)# transfer-pattern 5…

(config-telephony)# transfer-pattern 9…

允许5开头的分机transfer电话至本地号码

  1. 配置呼叫驻留(call park):将一呼叫驻留在一分机号码上,任何一个可以拨打驻留分机号的电话都可以取回这个呼叫

(config)# ephone-dn 22

(config-ephone-dn)# number 7000

(config-ephone-dn)# park-slot 注:park-slot命令选项用途见书P132

(config-ephone-dn)# exit

  1. 配置呼叫代答(pick up)

(config)# ephone-dn 20

(config-ephone-dn)# pickup-group [组号]

代答方式:直接代答——按下PickUp输入振铃电话号码

组内代答——按下PickUp输入“*”既可以应答本组振铃话机

组间代答——按下PickUp输入组号,既可以应答其它组振铃话机

  1. 配置对讲电话:A和B可以设置快捷键,当A拨快捷键时B将在mute状态下自动应答此呼叫。原理上是利用快捷拨号和自动应答快捷拨号的配置来实现。

(config)# ephone-dn 60

(config-ephone-dn)# number a100  (设置无法从其它话机拨打的号码)

(config-ephone-dn)# intercom a101 label “manager” 显示为manager

(config-ephone-dn)# exit

(config)# ephone-dn 61

(config-ephone-dn)# number a101

(config-ephone-dn)# intercom a100 label “assistant”  显示为assistant

(config-ephone-dn)# exit

(config)# ephone 1

(config-ephone)# button 2:60

(config-ephone)# restart

(config)# ephone 2

(config-ephone)# button 2:61

(config-ephone)# restart

  1. 配置呼叫功能:提供单向的自动通信路径,CME寻呼系统要分配一个ephone-dn作为寻呼号码,呼叫此号码可对此寻呼组内IP话机进行广播,可方便一次性寻呼特定的部门

(config)# ephone-dn 80

(config-ephone-dn)# number 5555

(config-ephone-dn)# paging

(config)# ephone-dn 81

(config-ephone-dn)# number 5556

(config-ephone-dn)# paging

(config)# ephone-dn 82

(config-ephone-dn)# number 5557

(config-ephone-dn)# paging group 81,82  注:支持10个组

(config-ephone-dn)# exit

(config)# ephone 1

(config-ephone)# paging-dn 80

(config-ephone)# exit

(config)# ephone 2

(config-ephone)# paging-dn 80

(config-ephone)# exit

(config)# ephone 3

(config-ephone)# paging-dn 81

(config-ephone)# exit

(config)# ephone 4

(config-ephone)# paging-dn 81

(config-ephone)# exit

拨打5555可向ephone 1 2进行广播

拨打5556可向ephone 3 4进行广播

拨打5557可向ephone 1 2 3 4进行广播

  1. 配置时间段呼叫阻塞:阻止下班后产生过量未经授权的呼叫

①  定义非工作时间的天数或者一天内的小时数

②  在步骤1指定时间内指定阻塞模式

③  根据需要创造不受策略影响的模式

(config)# telephony-service

(config-telephony)# after-hours day [mon – fri] [start_time] [end_time]

(config-telephony)# after-hours pattern 1 91……… 共可设置32个阻塞模式

(config)# ephone 1

(config-ephone)# after-hour exempt

(config-ephone)# exit

(config)# ephone 2

(config-ephone)# pin 1234

(config-ephone)#exit

(config)# telephony-service

(config-telephony)# login timeout 120 clear 23:00

设置下班时间;设置阻塞模式1为禁止拨打本地手机号;ephone 1为不受时间呼叫阻塞策略限制,ephone 2输入pin码后不受时间阻塞策略限制;最后两行是启动PIN值的关键一步,所有话机上会显示Login输入PIN值后才能激活,一到晚上23:00就会被清除,但可以再次输入PIN值

  1. 配置CDR和呼叫统计

(config)# logging buffered 512000

(config)# dial-control-mib retain-timer 10080

(config)# dial-control-mib max-seze 700

分配512000字节用于记录,CDR保存10080分钟(7天),最多保存700条CDR

# show logging  查看CDR记录

若有系统日志服务器:

(config)# gw-accounting syslog  引导CDR记录到日志服务器

(config)# logging  [ip_address] 日志服务器IP地址

  1. 配置保持音乐:CME可将拷贝在flash中的特定WAV  AU音频文件转换为保持音乐音频流,CME可以多个单播流(资源依赖高)或单个多播流(资源依赖小但要求多播网络配置)

例:将flash中的bonjovi.wav音频做为多播MoH

(config)#  telephony-service

(config-telephony)# moh bonjovi.wav

(config-telephony)# multicast moh 239.1.1.55 prot 2123

  1. 启用CME GUI

首先确定已将GUI文件装载进CME路由器的flash中

# dir flash:

然后将CME配置为一台WEB服务器:

(config)# ip http server  启用HTTP

(config)# ip http secure-server  启用HTTPS

(config)# ip http path flash:/gui 使用GUI文件来响应HTTP&HTTPS请求,文件根据实际位置可修改

(config)# ip http authentication local 使用本地数据库对用户进行验证

创建CME Web管理员账号并给予权限

(config)# telephony-service

(config-telephony)# web admin system name [用户名] secret 0 [密码]

(config-telephony)# dn-webedit 打开web界面配置ephone-dn

(config-telephony)# time-webedit 打开web界面配置CME的时间

网关和Trunk的概念

  1. 模拟和数字信号转换

采样:柰奎斯特定理——-采样频率是模拟信号最大频率的2倍(或以上)信号就可以可靠的还原(人讲话为200—9000HZ,采样率为8000HZ,所以能再现300—4000HZ)

量化:每次采样使用8位2进制编码表示,则每秒8000*8=64000比特(64kbit/s)

a律—-正数第一位为1;Mu律是将a律全反

编码、压缩:

编解码器占用带宽
G.71164kbit/s   注:未压缩
G.7298kbit/s
G.729a8kbit/s
iLBC15.2kbit/s

数字信号处理器DSP(digital signal processors):代替路由器承担处理语音的任务,是集采样、编码、压缩处理为一体的芯片,可直接添加到路由器主板或网络模块

数据包语音DSP模块PVDM(packet voice DSP modules):

PVDM2-85个DPS芯片
PVDM2-161个DSP芯片
PVDM2-322个DSP芯片
PVDM2-483个DSP芯片
PVDM2-644个DSP芯片
  1. 计算编解码器带宽要求

确定音频编解码器自身所占用带宽

带宽=(采样周期*编解码器每秒带宽数bit/s)/ 8

确定数据链路层、网络层、传输层开销

以太网:20 bytes

帧中继:4—6 bytes

PPP协议:12 bytes

IP:20 bytes

UDP: 8 bytes

RTP: 12 bytes

确定附加开销

GRE/L2TP: 24 bytes

MPLS: 4 bytes

IPsec: 50—57 bytes

  1. RTP—real-time transport protocol和RTCP—real-time control transport protocol协议
语音信息UDPRTPIP数据链接
负载类型顺序号时间戳

 

RPT在UDP之上,为每个RTP流选择UDP端口16384—-32767中的一个偶数端口,RTCP会使用一个相同范围的奇数端口,RTP是单向流

配置并验证网关和Trunk

  1. 配置模拟语音端口

#show voice port summary  识别语音端口

配置FXS语音端口信号发送

(config)# voice-port 0/0/0

(config-if)# signal [loopstart /groundstart]接地启动连接PBX时使用回路启动连接模拟设置时使用

(config-if)# cptone  CN 选择拨号音

(config-if)# station-id name  [name]

(config-if)# station-id number  [xxxxxxxx]

配置FXO语音端口

(config)# voice-port 0/0/1

(config-if)# signal [loopstart /groundstart]接地启动连接PBX时使用回路启动连接模拟设置时使用

(config-if)# cptone  CN 选择拨号音

(config-if)# station-id name  [name]

(config-if)# station-id number  [xxxxxxxx]

(config-if)# dial-type  [dtmf / pulse]  选择使用双音多频 / 脉冲拨号

(config-if)# ring number [1–10]  路由处理呼叫前的振铃次数

  1. 配置数字语音端口:CISCO以语音和WAN接口卡VWIC(voice and wan interface cards)为路由提供E1端口,配置VWIC时:ds0-group用于E1的CAS连接;

配置CASPSTN端口

# show controllers e1  查看E1接口

(config)# controller e1 1/0

(config-controller)# framing  esf

(config-controller)# linecode  b8zs

(config-controller)# clock source line 向服务提供商接收接口时钟,连接PSTN时

(config-controller)# clock source internal 向PBX系统提供时钟信息,连接PBX时

(config-controller)# ds0-group 1 timeslots 1-30 type fxo-loop-start

注:可以将一E1接口分到多个ds0-group,用于连接多个接口

配置CCSPSTN端口

(config)#  isdn switch-type  [交换机型号]  和服务提供商使用类型匹配

(config)# controller e1 1/0

(config-controller)# pri-group timeslots 1-30  注:信道16(17时隙)总是信令信道

  1. 配置拨号对等体

POTS拨号对等体:用于对传统语音连接定义语音可达信息

VoIP拨号对等体:用于为任意VoIP连接定义语音可达信息

配置路由器上FXSPOTS拨号对等体:

# show dial-peer voice summary   查看所有拨号对等体

(config)# dial-peer voice [tag] pots

(config-dial-peer)# destination-pattern  [分机号码]

(config-dial-peer)# port 0/0/0

配置路由器与PBX或服务供应商的FXOPOTS拨号对等体:

(config)# dial-peer voice  [tag] pots

(confgi-dial-peer)# destination-pattern 9T

(config-dial-peer)# no digit-strip   禁止自动号码移除

(config-dial-peer)# port 1/0:30

将所有拨打2xxx分机的呼叫都送至E1 1/0接口

 配置VoIP拨号对等体:

       (config)# dial-peer voice  [tag]  voip

(config-dial-peer)# destination-pattern 2…

(config-dial-peer)# session target ipv4:[ip_address]

(config-dial-peer)# codec g711alaw    若编码不匹配则不能接通

  1. 使用拨号对等体通配符
通配符描述
句点(.)20..匹配2000——2099
加号(+)5+23 匹配5523、55523、5555523,最多32位
方括号([])[1-3]23 匹配123、223、323;[^1-8]23匹配023、923、*23
T9T 匹配9开关的所有号码
逗号(,)在已拨号码中插入1秒暂停

例:(config)# dial-peer voice 90 ports

(config-dial-peer)# description example_1

(config-dial-peer)# destination-pattern 9[469]11

(config-dial-peer)# forwar-digits 3

(config-dial-peer)# port 1/0:30

(config-dial-peer)# exit

拨打9411、9611、9911号码从port 1/0 PRI端口送出,删除9、11号码

Forwar-digits 3 发送确定的3个号码,CME最后送出411、611、911

(config)# dial-peer voice 91 ports

(config-dial-peer)# description example_2

(config-dial-peer)# destination-pattern 90T

(config-dial-peer)# prefix 0

(config-dial-peer)# port 2/0:30

(config-dial-peer)# exit

拨打90开关的号码由port 2/0送出,删除9、0号码,prefix 0 在送出的号码前加0

  1. 专线自动回铃PLAR—-private line automatic ring down

(config)# voice-port 0/0/0

(config-voiceport)# connection plar 1102

注:对FXS语音端口0/0/0进行硬编码,只要用户摘机就拨打1102

对FXO语音端口0/0/0进行硬编码,只要打进电话就转到分机1102 (直线)

  1. 路由器的呼叫处理和数字处理

通过以下方法匹配入站拨号对等体

Incoming called-number匹配被叫号码(DNIS)

Answer-address匹配ID信息(ANI)

Destination-pattern匹配呼叫者ID信息(ANI)

POTS匹配并使用指定Port发送

最后使用对等体0

数据处理是向所拨号码添加或从所拨号码移除号码的过程:

命令模式描述
Prefix  [xxx]POTS拨号对等体向拨叫号码前添加xxx
Forward-digits  [NO]POTS拨号对等体发送从右侧开始的指定位数
[no] digit-stripPOTS拨号对等体[禁止] 默认号码移除
Num-exp [NO1]  [XXXX]全局将NO1替换为XXXX如:num-exp 4… 5…将4xxx替换为5xxx
Voice translation-profilePOTS拨号对等体或全局或VOIP拨号对等体允许配置文件

具体实例见书P192

Prefix可以添加号码;forward-digits可以确保移除号码;num-exp允许最大的变动,但这些变动全局应用于路由器不能灵活的变换;voice translation(转换配置文件)则可以实现。

配置转换文件分三步:

①  定义说明路由器如何转换号码规则

(config)# voice translation-rule rule  [NO]

(cfg-translation-rule)# rule 1 /match_number/ /set_number/

(cfg-translation-rule)# rule 2 /match_number/ /set_number/

(cfg-translation-rule)# rule 3 /match_number/ /set_number/

②  关联一个转换文件

(config)# voice translation-profile  [文件名]

(cfg-translation-profile)# translate called  [NO]

③  分配给一个拨号对等体

(config)# dial-peer voice 100 pots

(config-dial-peer)# translation-profile incoming [文件名]

  1. 设置服务质量,应用Cisco AutoQos

端到端延时:150ms或更少

抖动: 30ms或更少

数据包丢失率:1%或更少

switch

rout

Ip_phone

Fa0/3

Fa0/1

Fa0/0

Ip WAN

S0/0

可信任边界:决定该流量具有或不具有QoS标记。上例中将switch的fa0/3设为可信任边界

Switch:

(config)# interface fa0/3

(config-if)# auto qos voip  [cisco-phone / cisco-software]

(config-if)# exit

(config)# interface fa0/1

(config-if)# auto qos voip trust

# show run int fa0/1

Rout:

(config)# interface fa0/0

(config-if)# auto qos voip trust

(config-if)# exit

(config)# interface s0/0

(config-if)# auto qos voip trust

(config-if)# exit

Cisco Unity Express

  1. Cisco Unity Express类型与硬件

提供语音和自动应答服务,基于Linux或Windows系统。它和CME是不同的系统但可以在功能上进行交互操作。

Cisco Unity的3种产品系列

Cisco Unity ExpressCisco Unity connectionCisco Unity
邮箱25075007500
发送消息类型语音邮件与集成消息发送语音邮件与集成消息发送语音邮件与集成消息发送以及统一的消息发送
自动应答能力可以可以可以
平台Linux路由器Linux、Windows服务器Windows服务器
支持PBX/TDM不支持支持支持
冗余

Cisco Unity Express硬件型号:

Cisco Unity Express高级集成模块—–Cisco Unity Express Advanced Integration Moudle,AIM-CUE

Cisco Unity Express网络模块—–Cisco Unity Express Network Moudle,NT-CUE

增强型性能的Cisco Unity Express网络模块—-Cisco Unity Express Network Moudle With Enhanced Capability,NM-CUE-EC

Cisco Unity Express增强型网络模块—-Cisco Unity Express Enhanced Network Moudle,

NME-CUE

AIU-CUENM-CUENM-CUE-ECNME-CUE
邮箱50100250250
语音端口681624
安装主板插槽网络模块插槽网络模块插槽网络模块插槽
最大存储时间14小时100小时300小时300小时

注:AIM-CUE必须位于R3745的AIM1插槽里,若插在AIM0会损坏AIM-CUE

每个模块对不同的路由器的IOS版本都有要求(P215)

  1. Cisco Unity Express软件及授权

Cisco Unity Express语音邮件与自动应答软件

Cisco Unity Express可选IVR软件

Cisco Unity Express PC应用软件

授权受下面3方面因素影响:(P218)

连接Cisco Unity Expressr IP PBX类型

受权将要负载的Cisco Unity Express模块类型

Cisco Unity Express所需要的邮箱数据

  1. 安装Cisco Unity Express

安装Cisco Unity Express模块

安装并升级Cisco Unity Express软件

添加并验证Cisco Unity Express授权

安装Cisco Unity Express模块(P245)

一旦模块安装成功刚出现一个服务接口(service-engine),可通过show run显示

首先要给service-engie分配一个IP地址

(config)# interface service-engie 1/0

(config-if)# ip address  [ip_address_A] 或 ip unnumbered [loopback 0]

直接设定地址或与loopback 0共享IP地址

其次为service-moudle分配一个IP地址和默认网关

(config)# interface service-engie 1/0

(config-if)# service-moudle ip address [ip_address_B] [mask]

(config-if)# service-moudle ip default-gateway  [ip_address_A]

最后给发送到Cisco Unity Express的流量再添加一条路径

(config)# ip route [ip_address_B] 255.255.255.255  service-engie 1/0

安装并升级Cisco Unity Express软件(P250)

连接到Cisco Unity Express CLI

# service-moudle service-engie 1/0 session

向Cisco Unity Express硬件平台复制软件并在本地运行

CUE# software download [service/upgrade/clean] urlftp://ip_address/pack_name

运行来自FTP服务器的软件

CUE# software install [upgrade/clean] ufl ftp://ip_address/pack_name

注:upgrade升级;clean全新安装

CUE# software download sttus 查看运行中软件下载状态

CUE# software download abort 取消当前进行的软件下载

添加并验证Cisco Unity Express的授权(P252)

        CUE# software install clean url ftp://ip_address/pack_name

CUE# show software license

  1. Cisco Unity Express配置

①  安装或升级CUE软件后,系统会运行service-engine安装后期配置工具,以完成以下配置:主机名、域名、DNS、NTP服务器(ip_address_CME)、时区、管理授权 (P255)

②  配置CME以支持CUE

HTTP服务器选项

(config)# ip http server

(config)# ip http path flash:

(config)# ip http authentication local

CUE的拨号对等体

(config)# dial-peer voice 7000 voip

(config-dial-peer)# description voice_mail

(config-dial-peer)# destination-pattern 7000

(config-dial-peer)# session protocol sipv2

(config-dial-peer)# session target ipv4: [ip_address_of_service-module]

(config-dial-peer)# dtmf-relay sip-notify

(config-dial-peer)# codec g711alaw

(config-dial-peer)# no vad

CUE的电话服务配置

(config)# telephony-service

(config-telephony)# voicemail 7000

(config-telephony)# web admin system name [用户名] password [密码]

注:用户名和密码与CUE管理授权一致,可以同时管理CME和CUE

(config-telephony)# dn-webedit

(config-telephony)# time-webedit

MWI(message waiting indicator)配置:用于点亮IP话机的留音灯

(config)# ephone-dn 19

(config-ephone-dn)# number a40….

(config-ephone-dn)# mwi on

(config-ephone-dn)# exit

(config)# ephone-dn 20

(config-ephone-dn)# number a41….

(config-ephone-dn)# mwi off

(config-ephone-dn)# exit

当CUE发送号码a401000时,CME于ephone-dn 19匹配然后移除静态号码a40留下号码1000,CME将为分机1000点亮留音灯。同理,当CUE发送号码a401001时CME将关闭1001的留音灯


iqianyue , 版权所有丨如未注明 , 均为原创,转载请注明iqianyue
喜欢 (1)
[]
分享 (0)
发表我的评论
取消评论

表情 加粗 删除线 居中 斜体 签到

Hi,您需要填写昵称和邮箱!

  • 昵称 (必填)
  • 邮箱 (必填)
  • 网址